Fórum Root.cz

Hlavní témata => Distribuce => Téma založeno: crazyprogrammer 28. 09. 2010, 09:40:42

Název: Po instalaci nefunguje Arch ani jiná odvozená distra
Přispěvatel: crazyprogrammer 28. 09. 2010, 09:40:42
Ahojte,
zkoušel jsem nainstalovat na notebook Arch (HP Compaq NW8240 Mobile Workstation), vše bez problémů. Z Archu jsem byl nadšenej, tak jsem ho chtěl nainstalovat na desktop. Jenže ouha, po instalaci a restartu jsem se dostal jenom do promptu GRUBu (Arch používá GRUB1, ArchBang GRUB2, výsledek ale stejný) nebo mi vypsal error 20. To samý se mi stalo při instalaci Gentoo, KahelOS, ArchBang... Bez problému mi na počítači funguje Ubuntu a Fedora.

Tyto distra jsem zkoušel:
Ani jedno z nich nechtělo nabootovat. Buď GRUB error 20 nebo jsem se dostal do promptu GRUBu.

Můj počítač:
MB:  Asus P5K/EPU
CPU: Intel Core2Duo E7200 @ 2,53 GHz 2,53 GHz
RAM: Značku nevim, 4 GB
GFX: ATi Sapphire Radeon HD 3650
HDD1 (/dev/sda): Seagate Barracuda (víc nevím) 500 GB, tady chci /home
HDD2 (/dev/sdb): Western Digital (taky víc nevim) 140 GB, tady chci vše kromě /home


Díky za rady, crazyprogrammer.
Název: Re: Po instalaci nefunguje Arch ani jiná odvozená distra
Přispěvatel: Dalimil Gala 28. 09. 2010, 17:02:02
Error 20 jsem našel, že je problém s multibootem. Ověř si, kam, na který disk a partition se při instalaci opravdu grub instaluje. Je možné, že při instalaci systém vidí disky v jiném pořadí než Bios při bootu. Můžeš zkusit instalovat jen s jediným diskem a druhý připojit až po instalaci.
Název: Re: Po instalaci nefunguje Arch ani jiná odvozená distra
Přispěvatel: crazyprogrammer 28. 09. 2010, 18:14:49
To mě nenapadlo zkoušet, tak uvidíme... Potom napíšu výsledek. Díky za radu!
Název: Re: Po instalaci nefunguje Arch ani jiná odvozená distra
Přispěvatel: crazyprogrammer 28. 09. 2010, 19:15:26
Hmm, tak po instalaci a restart jsem se dostal do promptu GRUBu 1.97... crazyprogrammer
Název: Re: Po instalaci nefunguje Arch ani jiná odvozená distra
Přispěvatel: kei.101 28. 09. 2010, 19:18:10
To se mi nedávno taky stalo, pak jsem tam šoupnul "Super Grub Disk" a zkoušel bootovat a řeklo mi to, že BIOS nepodporuje bootování z tak vysokého sektoru. Zkuste dát boot oddíl blíže k začátku disku.
Název: Re: Po instalaci nefunguje Arch ani jiná odvozená distra
Přispěvatel: crazyprogrammer 29. 09. 2010, 15:58:30
/boot mám na prvním oddílu disku, nevím jestli v tom bude problém... každopádně díky za radu, zkusím ten "Super Grub Disk"
crazyprogrammer