Fórum Root.cz

Hlavní témata => Distribuce => Téma založeno: e.xitu.s 21. 05. 2010, 21:24:19

Název: Nefunguje root na Debianu
Přispěvatel: e.xitu.s 21. 05. 2010, 21:24:19
Dobrý den,
právě jsem reinstaloval systém, Debian (Gnome). Chtěl jsem si nainstalovat další aplikace, zapnu terminál, napíšu su root, heslo a nic. Zkouším to více-krát, ne jen v terminálu, ale i např. v Synapticu. Heslo nefunguje. Ale když se poté přihlásím do single-user módu a zadám heslo roota, vše mi najendou funguje, normálně se naloguji. Nevím v čem je problém, že by nějaká chyba v X Window?
Nevíte jak to vyřešit, protože se pořád nechci přihlašovat jako root v single-user módu, ale v normálním grafickém prostředí. Díky ;-)
Název: Re: Nefunguje root na Debianu
Přispěvatel: nazir 22. 05. 2010, 09:29:47
Jak přesně se to "nic" projevuje?  Vypíše to nějakou chybovou hlášku? 
Bez přesnějších informací bych to zatím tipoval na rozdílnou mapu klávesnice v textovém (single-user, tty*) a grafickém módu.  Máte v heslu pro roota nějaké písmeno x, nebo y?  Nebo nějaká čísla, která zadáváte přes alfanumerickou část klávesnice?
Název: Re: Nefunguje root na Debianu
Přispěvatel: e.xitu.s 22. 05. 2010, 10:23:57
No prostě když napíšu do terminálu su root, heslo, tak mi to napíše su selhání autentizace. Číslo tam mám, ale zkoušel jsem to zadávat přes numerickou klávesnici i přes abecední pole (či jak se tomu říká) + shift. Stejně mi to blbne i i přes správce balíků synaptic, když si chci aktualizovat systém vyskočí tam takové okno: "Zadejte správcovské heslo, aplikace xxx vás nechá měnit nezbytné části systému" Zadám heslo a nic. Aplikace se nespustí. Nefunguje mi spouštění okenních aplikací ani přes gksudo. Vypíše to, že jsem zadal špatné heslo. Zkusím si nainstalovat jiné grafické prostředí (nejspíš Fluxbox), uvidím, jestli je to chyba v X Window nebo jen v Gnome. Dříve mi to se starým systémem nedělalo.
Název: Re: Nefunguje root na Debianu
Přispěvatel: e.xitu.s 22. 05. 2010, 10:25:38
jo a ješte, nemám tam písmenko x ani y
Název: Re: Nefunguje root na Debianu
Přispěvatel: Ondřej Caletka 22. 05. 2010, 10:40:11
Zkus to heslo napsat na terminál, jestli se napíše stejně, jako bys očekával. Neměl jsi třeba při instalaci vypnutý numlock? Pak by se heslo skládalo z řídicích znaků, namísto číslic.

Taky bych zkusil Ctrl+Alt+F1 a přihlášení na textové konzoli. A až se ti povede přihlásit, změň si ho na nějaké jednoduché, třeba „heslo“, abys vyloučil chybu v rozdílných klávesnicích.

 A pak nevím, jak je to u debianu, ale některé distribuce dovolují používat su jen uživatelům ve skupině wheel, takže můžeš jako root zkusit:
Kód: [Vybrat]
gpasswd -a jmenouzivatele wheel
Název: Re: Nefunguje root na Debianu
Přispěvatel: H0ax 22. 05. 2010, 11:18:00
buď "su" a nebo "sudo příkaz" a nebo "sudo su", that's all
Název: Re: Nefunguje root na Debianu
Přispěvatel: PCnity 22. 05. 2010, 13:31:19
Nakolko debian nema standarne nastaveny /etc/sudoers, pokial si to nenastavil user sam, o com by asi vedel, moze na tutop moznost zabudnut!

Zdielam nazor ze problem je v keyboard layoute. Odporucam tiez stlacit CTRL + ALT + F1 a skusit sa tam prihlasit ako root a potom proste passwd a zmenit ho na primitivne heslo bez cisiel, specialnych znakov alebo zmeneneho caseu.

Pokial ani toto nepoze, chod znova do sigle rezimu a zmen tam to heslo na primitovne.

EDIT: U v Debiane som defaultne v grupe wheel po installacii. Cize tam by problem byt nemal.
Název: Re: Nefunguje root na Debianu
Přispěvatel: e.xitu.s 22. 05. 2010, 16:49:47
Nainstaloval jsem i Fluxbox, tam mi to dělalo taky. Poté jsem spustil virtuální konzoli (alt+ctrl+f1) a přihlásit se jako root už šlo. Tak jsem si heslo změnil na 4-místné a už to funguje. Nevím, kde by mohla být chyba, asi špatné rozložení klávesnice, místo číslic jsem napsal znaky nad nimi
(já blb ;-)). Ale děkuji za pomoc!