Fórum Root.cz

Hlavní témata => Distribuce => Téma založeno: czechsys 15. 02. 2022, 10:18:47

Název: Lze zablokovat instalaci další verze PHP?
Přispěvatel: czechsys 15. 02. 2022, 10:18:47
Ahoj,

bezim servery s php7.4 z repozitare deb.sury.org. Verzi si ridim skrz ansible, jen jsem zatim neprisel na to, jak zablokovat out-of-box instalaci ruznych verzi pro danou verzi debianu. Tzn., skacou mi tam 5.6 ~ 8.1 verze momentalne.

Existuje moznost nastavit apt, aby videl jen tu 7.4 (plus max. default deb repo), resp, aby aspon nevidel ty "novejsi" verze? Starsi takovy problem nejsou, update-alternatives to drzi na te "nejnovejsi nainstalovane".

preferences.d/php:
Kód: [Vybrat]
Package: *
Pin: origin packages.sury.org
Pin-Priority: 450
Název: Re:Lze zablokovat instalaci dalsi verze php?
Přispěvatel: Michal Žažo 15. 02. 2022, 10:32:34
Tohle by nepomohlo ?
https://askubuntu.com/questions/18654/how-to-prevent-updating-of-a-specific-package
Název: Re:Lze zablokovat instalaci dalsi verze php?
Přispěvatel: czechsys 15. 02. 2022, 10:53:31
Hold znam, ale zrovna u php si s nim jisty nejsem. Nejedna se totiz o upgrade tech samych baliku, ale instalace dalsi verze vedle soucasne. Navic, nechci holdovat soucasnou verzi, tam bych potreboval prubezne aktualizace funkcni bez nutnosti deaktivovat hold (v tu chvili by se tam mohla nacpat i ta jina verze...).
Název: Re:Lze zablokovat instalaci další verze PHP?
Přispěvatel: novak_josef_2019 15. 02. 2022, 11:35:48
Tohle by mi též bodlo, protože když jsem zkusil někdy před měsícem přehodit z php7.4 na php8.0 Wordpress nebo Nextcloud (oba jsou up-to-date), tak oba zkolabovaly a to už mám nainstalovanou i verzi php8.1 od Ondřeje.
Název: Re:Lze zablokovat instalaci další verze PHP?
Přispěvatel: Petr Krčmář 15. 02. 2022, 11:36:53
Ty balíčky různých verzí jsou nezávislé, propojené jsou přes metalíček php (https://packages.debian.org/bullseye/php), který vždycky odkazuje závislostí na jednu verzi. Třeba v Debianu Bullseye závisí tenhle balíček na balíčku php7.4. Čili řešení spočívá v tom vůbec neinstalovat ten metabalík php, ale vybrat si přímo verzi, kterou chcete. Ta se pak bude normálně aktualizovat, jak budou přijíždět nové verze toho balíku.
Název: Re:Lze zablokovat instalaci další verze PHP?
Přispěvatel: czechsys 15. 02. 2022, 11:55:59
Ty balíčky různých verzí jsou nezávislé, propojené jsou přes metalíček php (https://packages.debian.org/bullseye/php), který vždycky odkazuje závislostí na jednu verzi. Třeba v Debianu Bullseye závisí tenhle balíček na balíčku php7.4. Čili řešení spočívá v tom vůbec neinstalovat ten metabalík php, ale vybrat si přímo verzi, kterou chcete. Ta se pak bude normálně aktualizovat, jak budou přijíždět nové verze toho balíku.

Pokud nebude jeste nejake dalsi moznosti, tak zrejme pujdu touto cestou, uz jsem o vylouceni metabaliku php uvazoval, protoze jako nutnou zavislost ma php-fpm/cgi/whatever, coz zrovna na nekterych serverech spis nepotrebuju (staci php-cli).
Název: Re:Lze zablokovat instalaci další verze PHP?
Přispěvatel: Petr Krčmář 15. 02. 2022, 12:57:44
Ty metabalíky nejsou vůbec v systému nutné, jsou k dispozici jen jako ulehčení instalace: nainstaluj jeden balík a zbytek přijede sám. Pokud vám to ale překáží, můžete je normálně odinstalovat a poskládat si pak ostatní balíčky podle svého uvážení. Pokud používáte Ansible, tak to bude triviální operace.
Název: Re:Lze zablokovat instalaci další verze PHP?
Přispěvatel: novak_josef_2019 15. 02. 2022, 15:36:28
Mám Ubuntu 18.04, kde je standardně (snad) dostupná verze 7.2. Do repozitářů jsem přidal 'add-apt-repository ppa:ondrej/php' a to se doinstalovala verze 7.4 a dál se automaticky aktualizuje na 8.0, 8.1 a určitě dál.
Název: Re:Lze zablokovat instalaci další verze PHP?
Přispěvatel: czechsys 16. 02. 2022, 10:31:59
Hm. Tak ted koukam na ty servery a metabalik php nemam vubec nainstalovany...

A jeste oprava:
Problem s tahanim fpm baliku do serveru, kde nejsou zadouci, je primo v php7.4 - to ma zavislost na:
Kód: [Vybrat]
libapache2-mod-7.4 | php7.4-fpm | php7.3-cgi
Takze to spis vypada, ze bych pro cli servery bych se spis mel zbavit i php7.4 baliku...
Název: Re:Lze zablokovat instalaci další verze PHP?
Přispěvatel: czechsys 17. 02. 2022, 11:12:51
Tak celkove reseni je:
1] odinstalace vsech baliku php, php-jmenomodulu
2] odinstalace baliku php7.4 (pro compute servery, zbaveni se zbytecneho fpm modulu)
3] odinstalace vsech baliku ostatnich phpX.Y

V systemu pak zustane jen 7.4 a pri upgradu se jiz nic nevaze zavislostmi na pridavani novych verzi - pridavaly se napr. diky baliku php-geoip apod.