Fórum Root.cz

Hlavní témata => Distribuce => Téma založeno: okalousek 29. 07. 2020, 23:52:32

Název: Příliš starý balíček python3-cloudflare
Přispěvatel: okalousek 29. 07. 2020, 23:52:32
Chci si zřídit wildcard pro acme, ale pro nové limitované API Tokeny je třeba mít verzi 2.4 přičemž Debian 10 má 2.1. Mohl bych si stáhnout deb balíček a nainstalovat ho ručně, nebo to udělat přes PIP (což se mi nechce). Existuje pro to nějaké repo, nebo je i jiné řešení?
Název: Re:Příliš starý balíček python3-cloudflare
Přispěvatel: ByCzech 30. 07. 2020, 04:48:33
Můžete si balíček vyrobit pomocí python-stdeb. Zkusil jsem a vypadá, že se vyrobil bez potíží (příloha)...
Název: Re:Příliš starý balíček python3-cloudflare
Přispěvatel: okalousek 31. 07. 2020, 01:31:32
Hezké, děkuji, ale jako na potvoru to vyžaduje další a další balíčky že to raději vymyslím tím PIPem.
Název: Re:Příliš starý balíček python3-cloudflare
Přispěvatel: popelar 06. 08. 2020, 17:36:03
Hezké, děkuji, ale jako na potvoru to vyžaduje další a další balíčky že to raději vymyslím tím PIPem.

Pro zajimavost, proc jste se chtel puvodne PIPu vyhnout?
Název: Re:Příliš starý balíček python3-cloudflare
Přispěvatel: okalousek 07. 08. 2020, 23:46:38
Hezké, děkuji, ale jako na potvoru to vyžaduje další a další balíčky že to raději vymyslím tím PIPem.

Pro zajimavost, proc jste se chtel puvodne PIPu vyhnout?

Nepřijde mi to v tomto případě jako nejelegantnější řešení. Jenže raději než abych tomu dal kompletní API přístup, spokojím se se .venv (divné že certbot venv oficiální skript instaluje Python 2.7 i když ho certbot vlastně nevyžaduje...)