Fórum Root.cz

Hlavní témata => Sítě => Téma založeno: lordrak 23. 08. 2019, 11:18:28

Název: IPv6 Poda
Přispěvatel: lordrak 23. 08. 2019, 11:18:28
Ahoj,
omlouvám se za další téma na téma IPv6 ...
Bohužel jsem zatím nepronikl do tajů IPv6. Internet mám od společnosti Poda a router od Mikrotiku. Přípojka GPON s Huawei modemem v bridge módu.
Nastavení Mikrotiku:
/ipv6 dhcp-client
add interface=ether1-gateway pool-name=poda request=address,prefix

/ipv6 address
add address=::1 from-pool=poda interface=bridge-local

/ipv6 nd
add advertise-dns=yes interface=bridge-local managed-address-configuration=yes reachable-time=1m retransmit-interval=10s

/ipv6 route
add distance=1 gateway=fe80::f61d:6bff:fed4:31eb%ether1-gateway

/ipv6 settings
set accept-router-advertisements=yes

Dostanu prefix 2a00.../64 a na ether1-gateway dostanu adresu ::5
Na bridge-local mám adresu ::1 z poolu poda (tedy stejný pool jako ether1-gateway)
Zařízení v síti jsou Windows 10 a Android 8,9
firewal pravidla mám, ale i když všechny vypnu, situaci to nemění.

Co funguje:
Zařízení v síti mají adresu 2a00../64 a fe80..
Zařízení se pingnou navzájem na adresách fe80..
Z routeru si ping ipv6 v internetu (interface ether1-gateway nebo nezvolen)

Co nefunguje
Zařízení si Nepingnou na 2a00..
Ze zařízení si Nepingnu veřejné ipv6
Z mikrotik si Nepingnu veřejné ipv6 z  brigge-local
Zarížení -> mikrotik:
    Adresa ::1 (brigge-local) -> Request timed out (Wireshark - no response found)
    Adresa ::5 (ether1-gateway) -> Destination host unreachable (Wireshark - no response found)
    Adresa 2001:67c:68::76 (root.cz) -> Destination host unreachable (Wireshark - no response found)
Při pokusu na https://www.test-ipv6.cz/ vidím ve wiresharku jen syn packety bez odpovědi.

Na FW mám logování v chain forward, kde vidím při ping Stanice-> Internet jen packet syn (nicméně odezvu asi vidět nemusím)
Pokud zkusím ping Mikrotik -> stanice, tak ve wiresharku na stanici nevidím žádný pokus o komunikaci.


Prosím o názor, čím by to mohlo být.
Děkuji
Marek
Název: Re:IPv6 Poda
Přispěvatel: Ondřej Caletka 23. 08. 2019, 21:39:45
Pošli pokud možno nefiltrovaný výpis těchto příkazů:
Kód: [Vybrat]
/ipv6 dhcp-client print detail
/ipv6 pool used print detail
/ipv6 route print detail

Bohužel zkracování v podobě „2a00../64“ činí jakoukoli analýzu nemožnou. Chceš-li adresu znečitelnit, vyhvězdičkuj druhý a třetí blok, zbytek je důležitý pro pochopení situace.
Název: Re:IPv6 Poda
Přispěvatel: DgBd 23. 08. 2019, 21:40:41
::1 je loopbacková adresa, z toho ping nepůjde. ::5 bude patrně podobný případ.

v adresách imho chybí /64

/ipv6 address
add address=::1/64 from-pool=my-ipv6 interface=to-clients advertise=yes

ND (neighbor discovery):
managed-address-configuration=yes znamená, že přidělujete IPv6 adresy nějakým způsobem z DHCPv6 serveru, ale DHCPv6 server vám patrně neběží (nebo jste ho nezveřejnil). Normálně se používá automatická konfigurace IPv6 adresy pomocí SLAAC, tj. do sítě se přes neighbor discovery oznamuje pouze prefix a klient si IPv6 adresu vytvoří sám ze své MAC adresy.

pro začátek bych zkusil úplně nejtriviálnější konfiguraci jako CE1 z https://wiki.mikrotik.com/wiki/Manual:IPv6/DHCP_Client
Název: Re:IPv6 Poda
Přispěvatel: lordrak 24. 08. 2019, 23:52:15
Ahoj Ondro,
díky za ochotu.
Níže jsou výpisy

ipv6 dhcp-client print detail
Flags: D - dynamic, X - disabled, I - invalid
 0    interface=ether1-gateway status=bound duid="0x00030001d4ca6ded1f87" dhcp-server-v6=fe80::f61d:6bff:fed4:31eb request=address,prefix
      add-default-route=no use-peer-dns=yes pool-name="poda" pool-prefix-length=64 prefix-hint=::/0 dhcp-options=""
      prefix=2a00:xxxx:xxxx:a8b4::/64, never address=2a00:xxxx:xxxx:a8b4::5, never

/ipv6 pool used print detail
 pool=poda prefix=2a00:xxxx:xxxx:a8b4::/64 owner="Address" info="bridge-local"

/ipv6 route print detail
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, o - ospf, b - bgp, U - unreachable
 0 A S  dst-address=::/0 gateway=fe80::f61d:6bff:fed4:31eb%ether1-gateway gateway-status=fe80::f61d:6bff:fed4:31eb%ether1-gateway reachable
        distance=1 scope=30 target-scope=10

 1 A S  ;;; Defaultn  routa do Internetu jen pro ve ejn  bloky IPv6
        dst-address=2000::/3 gateway=fe80::f61d:6bff:fed4:31eb%ether1-gateway gateway-status=fe80::f61d:6bff:fed4:31eb%ether1-gateway reachable
        check-gateway=ping distance=1 scope=30 target-scope=10

 2 X S  ;;; Defaultn  routa do Internetu jen pro ve ejn  bloky IPv6
        dst-address=2000::/3 gateway=2a00:xxxx:xxxx:a8b4::1 gateway-status=2a00:xxxx:xxxx:a8b4::1 inactive distance=1 scope=30 target-scope=10

 3 ADC  dst-address=2a00:xxxx:xxxx:a8b4::/64 gateway=ether1-gateway,bridge-local,ether1-gateway
        gateway-status=ether1-gateway reachable,bridge-local reachable,ether1-gateway reachable distance=0 scope=10

 4 ADC  dst-address=fd00:1::/64 gateway=bridge-local gateway-status=bridge-local reachable distance=0 scope=10
 
Ad routy. V tuto chvíli mám u DHCPv6 klienta vypnutou možnost Add def. route, protože jsem něco testoval. Defaultní routa 0:: ale přesně odpovídá té, kterou vygeneruje DHCP klient.


DgBd
díky za odpověď. Zaponměl jsem napsat, že adresa ::1 a ::5 je z poolu přiděleného prefixu. Takto se to zadává a MK z toho vygeneruje celou adresu.
SLAAC mám nastaveno pomocí ND.
Nicméně ve světě IPv6 jsem nováček ... tak se omlouvám, jestli něco píši prostichůdně nebo nesmyslně.
Název: Re:IPv6 Poda
Přispěvatel: Ondřej Caletka 26. 08. 2019, 09:44:42
Kód: [Vybrat]
ipv6 dhcp-client print detail
Flags: D - dynamic, X - disabled, I - invalid
 0    interface=ether1-gateway status=bound duid="0x00030001d4ca6ded1f87" dhcp-server-v6=fe80::f61d:6bff:fed4:31eb request=address,prefix
      add-default-route=no use-peer-dns=yes pool-name="poda" pool-prefix-length=64 prefix-hint=::/0 dhcp-options=""
      prefix=2a00:xxxx:xxxx:a8b4::/64, never address=2a00:xxxx:xxxx:a8b4::5, never
Tohle je velmi zajímavé. Znamená to, že ISP ti přiděluje prefix /64 (aargh!) a zároveň adresu z toho stejného prefixu. To mi nepřipadá jako úplně ideální nastavení. V každém případě protože máš jen jeden prefix /64, nemáš jak oadresovat WAN linku, takže ta musí zůstat bez veřejných adres.

Čili nastavení DHCP klienta změň, aby žádal pouze o prefix, ne o adresu:
Kód: [Vybrat]
/ipv6 dhcp-client set 0 request=prefix add-default-route=yes
Ruční záznamy ze směrovací tabulky smaž, nech tam jen default route, kterou tam vloží DHCP klient.

No a konečně na rozhraní bridge-local nech přiřadit adresu z poolu (všechny ostatní adresy předtím smaž):
Kód: [Vybrat]
/ipv6 address add from-pool=poda interface=bridge-local address=::1
Nastavení ND nech výchozí:
Kód: [Vybrat]
/ipv6 nd
set [ find default=yes ] advertise-dns=yes advertise-mac-address=yes disabled=no hop-limit=unspecified interface=\
    all managed-address-configuration=no mtu=unspecified other-configuration=no ra-delay=3s ra-interval=3m20s-10m \
    ra-lifetime=30m reachable-time=unspecified retransmit-interval=unspecified
/ipv6 nd prefix default
set autonomous=yes preferred-lifetime=1w valid-lifetime=4w2d

Takhle by to mělo fungovat. Na WAN straně bys neměl vidět žádné veřejné adresy, na LAN straně bude na routeru tvůj prefix končící ::1. Ostatní zařízení si vylosují adresy ze stejného prefixu.

Název: Re:IPv6 Poda
Přispěvatel: ksfj 28. 08. 2019, 09:40:34
K pridelovani /64 od PODY bych chtel podotkout - pokud mas router od nich - tj. nejsi v bridge modu, tak to nejak i funguje.

Pokud si v bridge (predpokladam, ze mas verejnou IPv4) tak mi technik tvrdil, ze to nejak zatim neumi na delegovat.
Ale pokud to podle zde popisu rozchodis - dej vedet. Ja to na ubiquiti edgerouteru zatim taky nerozchodil.
Název: Re:IPv6 Poda
Přispěvatel: lordrak 11. 09. 2019, 19:57:38
Ahoj,
tak výsledek je zatím nulový.
Ano, mám jejich router v bridge módu. Dodávají ho tak automaticky s pevnou IPv4.
Pro tuto chvíli je jediné řešení NDP proxy nebo ebtables. Bohužel ani jedno mikrotik neumí (ebtables zrušil již dávno). Ubiquiti taky na tom není slavně, co jsem četl. Někteří technici reagovali na IPv6 a hlavně na požadavek na prefix /56 poněkud podrážděně, jako bych jim nadával. Nicméně /56 nikdo nedostane, protože s tím nepočítá jejich infrastruktura. Ale zase mi navrhli všechny dostupné možnosti napsané na začátku.
Avšak jsem dostal náznak, nikoliv však příslib, že by delegaci chtěli mít zprovozněnou v 1. kvartále 2020.
Budeme jim držet palce.
Ještě zkusím meta router, ale nedávám si moc šancí.
Název: Re:IPv6 Poda
Přispěvatel: alex6bbc 11. 09. 2019, 22:05:38
mam taky podu, moc do hloubky jsem tuhle diskuzi nesledoval.
ale pokud budete souhlasit, tak klidne jako dalsi klient zazadam o IPv6 adresu, taky jsem na gpon optice.

muzu v dotazu na podu pouzit link na tuhle diskuzi, at se chlapci trosku zapoti?
Název: Re:IPv6 Poda
Přispěvatel: lordrak 11. 09. 2019, 22:50:19
Ahoj, klidně použij, ale pokud nemáš na GPON placenou statickou IPv4 a tedy router v bridge modu, pak ti IPv6 bude (by měla) fungovat rovnou, protože nastavení routeru s tím podle techniků z PODY počítá.
Název: Re:IPv6 Poda
Přispěvatel: Hornik 11. 09. 2019, 22:58:53
Pokud mas GPON od PODY tak jiz mas aktivovanou IPv6 (/64 na zakaznika).

V pripade ze si priplacis za verejnou IPv4 pak za Huawei zarizenim mas svuj router. A jelikoz jim nefunguje prefix delagation tak v6 adresu ma Huawei GPON a pak WAN tveho routeru. Klienti uz maji smulu a je nutne to resit NDP nebo ebtables. Over si na svem PC nebo routeru, ze mas v6 adresu.

A obratem napis na PODU ze chces pridelit /56 nebo lepe /48 a link na tento thread jim priloz :)

Vzkaz pro CTO PODY Trcku --- "Udelejte uz v6 deployment konecne spravne. Tohle je ostuda!"
Název: Re:IPv6 Poda
Přispěvatel: piCZus 11. 09. 2019, 23:04:56
Také mám PODU a Huawej v bridge. U VPN používám NDP proxy, ale pro vnitřní síť NAT66 (radvd+isc-dhcp-server6).
Název: Re:IPv6 Poda
Přispěvatel: Hornik 12. 09. 2019, 08:23:45
Jan Betik @ Cesnet letos na IPv6 seminari tvrdil ze /56 od PODY ma.

https://www.youtube.com/watch?v=gfJWtCYYpxc
Název: Re:IPv6 Poda
Přispěvatel: Jan Crhán 04. 10. 2019, 13:56:29
   To mě tvrdil taky, zažádal si o to před roky mezi prvnímy, já jsem si o to požádal později a dostal jsem už jen /62.  To mi fungovalo i s delegací prefixu až do převodu na GPON v únoru tohoto roku. Od té doby to nefunguje. Průběžně kontaktuji technickou podporu kde mi postupně byly sdělovány tyto důvody proč to nefunguje: "Máme zastaralý hardware, čekáme na upgrade", "Máme vadný hardware, čekáme na nedostupné náhradní díly", "Máme hardware Huawei, hledáme jak to zprovoznit", "Nefunguje to nikomu na GPON, po zprovoznění budeme klienty informovat hromadným e-mailem". Postupně pozoruji pomalý postup. Do konce léta nefungovalo nic v IPV6. Nyní dostávám jak ostatní z PODY /64 adresy bez delegace prefixu.
Název: Re:IPv6 Poda
Přispěvatel: MObi 04. 10. 2019, 16:15:53
Dobrý den.
Taky mám GPON od Pody, a marně sem si lámal hlavu proč mi nejde IPV6 na RB450G když ho dám jako router, když ho nechám v Bridge tak vše šlape, ale teď koukám že to je chyba na straně Pody, s mikrotikem zase tak dobře neumím kdysi jsem dostal krátké zaškolení a to jenom na wifi a IPV4 . tak budu rád jak to bude v provozu když mi nekdo potom vysvětli co a jak , děkuji všem
Název: Re:IPv6 Poda
Přispěvatel: novak_josef_2019 01. 11. 2019, 15:43:33
Ano u PODY je snad od března IPv6 nefunkční. Měl jsem u známého přístup přes IPv6 na jeho NAS, bylo to za prefixem 2a00:ca8:a1f:*. Známý tomu moc nerozumí a nechce je prudit, ale za mě je to bída a velmi špatná vizitka této firmy. Díval jsem se jim do všeobecných podmínek a v nich mají, že NET je funční přes IPv4 nebo IPv6, takže jakoby žádný problém.
Netušíte náhodou někdo (zevnitř), jestli jim ještě někdy ta IPv6 pojede?
Název: Re:IPv6 Poda
Přispěvatel: mracekp 08. 06. 2020, 16:16:15
Stare tema o kterem jsem se dozvedel ze stiznosti jednoho z nasich klientu.
Pro upresneni problemu:

Vyse zminovany problem se tyka klientu na GPON siti s verejnou IP. Na metalicke casti site dhcp-pd pro klientske routery funguje normalne.
GPON technologie mela slouzit pro pripojeni domacich klientu a soucasti navrhu bylo ze roli CPE plni ONT jednotka. Bohuzel tim ze si klient pozada o verejnou IP se zpravidla role CPE presouva na jeho router. ONT by nikdy prefix delegovat nemelo, nema z ceho. Ma jen jednu /64 pro LAN rozhrani a z tohoto prefixu prideluje klasicka host IPcka, pripadne oznamuje prefix pro SLAAC konfiguraci. Vice se od toho v soucastne konfiguraci cekat neda.

O problemu samozrejme vime. Zmena soucastneho stavu je bohuzel komplikovanejsi nez by se na prvni pohled mohlo zdat. Cela GPON infrastruktura je koncipovana jako zerotouch reseni, takze zmena musi probehnout v cele infrastrukture. Navic uprava adresniho planu a routovani je planovana s dalsimi velkymi zmenami v provisioning reseni. To celou akci bohuzel dela narocnejsi a mnohem komplikovanejsi nez by se z vnejsiho pohledu mohlo zdat. Bohuzel tento problem postihuje jen male mnozstvi klientu a z duvodu vytizeni personalnich kapacit neni mozne slibit nejake konkretni datum reseni.

Budte prosim trpelivi, myslime na Vas.
Pavel Mracek.
Název: Re:IPv6 Poda
Přispěvatel: vlhab 11. 09. 2020, 17:45:45
Zmenilo se u Poda neco? Uz funguje IPv6 na GPONu s vlastnim routerem poradne? Resim jestli neprejit po letech od Netboxu.
Název: Re:IPv6 Poda
Přispěvatel: Hornik 11. 09. 2020, 22:36:33
IPv6 u Pody beze zmeny, porad stejna tragedie.

Populisticky nasadili Gigabit resp 1000/300 v reakci na na exUPC a pustili do sveta novou IPTV platformu, ktera konecne nevyzaduje Flash, ale ma zatim problemy se stabilitou.

Jinak ticho po pesine...
Název: Re:IPv6 Poda
Přispěvatel: novak_josef_2019 11. 09. 2020, 23:03:33
Kdeže píšou o 1000/300?
https://www.poda.cz/novinky/
Název: Re:IPv6 Poda
Přispěvatel: Hornik 12. 09. 2020, 12:46:37
Najit neco na poda webu - to by mel problem i profesor Rubik se svym tymem.

https://www.poda.cz/1gbps

Hint - tarify se zobrazi pouze po zadani adresy.


Název: Re:IPv6 Poda
Přispěvatel: Tomáš G. 12. 09. 2020, 21:34:45
IPv6 u Pody beze zmeny, porad stejna tragedie.
Populisticky nasadili Gigabit resp 1000/300 v reakci na na exUPC

Tak exUPC taky není žádná výhra. IPv6 nemám vůbec, protože veřejnou IPv4 potřebuji víc a obojí najednou neumí. No a 1000/300 je akceptovatelný poměr na rozdíl od té parodie 1000/50 v podání exUPC.

BTW, má Poda ještě volitelné rychlosti, kdy musí být zachován součet, jako to kdysi nabízela? Pokud ano, tak tohle by pak mohlo jít přenastavit na symetrických 650Mbps.
Název: Re:IPv6 Poda
Přispěvatel: Hornik 12. 09. 2020, 23:16:41
Ano volitelne rychlosti stale funguji, tedy teoreticky si lze nastavit symatrickych 650Mbps jak pises.
Název: Re:IPv6 Poda
Přispěvatel: novak_josef_2019 13. 09. 2020, 06:17:00
Dík za tu rychlost, zajímavé že to mají tajné, protože v novinkách machrují se vším a není to ani v ceníku.
Název: Re:IPv6 Poda
Přispěvatel: Tomáš G. 13. 09. 2020, 08:19:44
Dík za tu rychlost, zajímavé že to mají tajné, protože v novinkách machrují se vším a není to ani v ceníku.
Úplně tajné to není. Na webu to mají, ale nejsem si jist, jestli to není něco zapomenutého, nebo to není jen pro nižší tarify. Podu nemám, takže nevím, jak vypadá ta jejich zmiňovaná klientská zóna.

https://www.poda.cz/volitelna-rychlost/
Název: Re:IPv6 Poda
Přispěvatel: ksfj 14. 09. 2020, 14:51:48
u pody mam jak verejnou tak funkcni ipv6.

Je nutne si na svojim routeru rozbehat NDPPD a pak uz to jede (na edgerouteru jsem musel misto RA pouzit DHCP6 a pridelovat "/65". Jedna pulka zustane jako brana a tak a druhou rozdelujes. (a NDPPD se postara o to ze to cele jako /64 beha a pinga :-))
Název: Re:IPv6 Poda
Přispěvatel: Hornik 14. 09. 2020, 17:27:29
u pody mam jak verejnou tak funkcni ipv6.

Je nutne si na svojim routeru rozbehat NDPPD a pak uz to jede (na edgerouteru jsem musel misto RA pouzit DHCP6 a pridelovat "/65". Jedna pulka zustane jako brana a tak a druhou rozdelujes. (a NDPPD se postara o to ze to cele jako /64 beha a pinga :-))

Podobny hack pouzivam na OpenWRT.

Nicmene to nic nemeni na faktu, ze implementace IPv6 je nespravna.
Název: Re:IPv6 Poda
Přispěvatel: . 15. 09. 2020, 06:18:13
IPv6 u Pody beze zmeny, porad stejna tragedie.
Populisticky nasadili Gigabit resp 1000/300 v reakci na na exUPC

Tak exUPC taky není žádná výhra. IPv6 nemám vůbec, protože veřejnou IPv4 potřebuji víc a obojí najednou neumí. No a 1000/300 je akceptovatelný poměr na rozdíl od té parodie 1000/50 v podání exUPC.

BTW, má Poda ještě volitelné rychlosti, kdy musí být zachován součet, jako to kdysi nabízela? Pokud ano, tak tohle by pak mohlo jít přenastavit na symetrických 650Mbps.
O jaké parodii je řeč? Upload 50 Mbps je pořád v rámci republiky nadstandard (uživatelé všemožných vesnických WiFi, DSL a ostatně i LTE by mohli vyprávět) a co se týká IPv6, tak k čemu je to v praxi dobrý? K ničemu, leda ve stylu "čím víc IPv, tím víc Adidas". I tak se ale dá IPv6 obstarat přes třetí stranu, např. Hurricane Electric Tunnelbroker. Sice tam není nijak oslňující rychlost kvůli známým potížím s Docsis modemy Compal, ale nějak to funguje (když je ta IPv6 fakt tak strašně nutná).
Co je na exUPC jasný klad je veřejná pevná IPv4 u business tarifů a veřejná IPv4 u home tarifů bez příplatku (Poda ji dává za +80 Kč měsíčně). A samozřejmě i televize, která má u exUPC bez jakéhokoliv příplatku v základu cca 30 programů a je automaticky součástí, když má člověk internet (a ještě se dá připojit televizorů kolik libo). Pro někoho třeba nepodstatný, ale u Poda se za TV doplácí v řádu několika set korun, protože nemají nic jinýho, než balík s 80 programy (což je samozřejmě pitomost jak zvon, když si člověk nemůže vybrat třeba jenom základ za pár kaček - nebo spíš vychcanost, aby člověka pořádně podojili) a navíc u Poda co TV, to extra set-top-box a opět za příplatek.
Název: Re:IPv6 Poda
Přispěvatel: vlhab 15. 09. 2020, 10:59:16
HE tunnel a podobne typicky nefunguje za carrieer grade NAT.

IPv6 pouzivam pro vzdaleny pristup do domaci site.

Pokud to ISP umoznuje, muzu si jako alternativu zaplatit verejnou IPv4, ale tezko dostanu vic nez 1. Nicmene z principu to nechci podporovat, umet IPv6 mi v roce 2020 prijde normalni.
Název: Re:IPv6 Poda
Přispěvatel: SB 15. 09. 2020, 12:46:41
Je nutne si na svojim routeru rozbehat NDPPD a pak uz to jede (na edgerouteru jsem musel misto RA pouzit DHCP6 a pridelovat "/65". Jedna pulka zustane jako brana a tak a druhou rozdelujes. (a NDPPD se postara o to ze to cele jako /64 beha a pinga :-))

Tak to je kvalita. Poda nezklamala.
Název: Re:IPv6 Poda
Přispěvatel: LukePole 15. 09. 2020, 12:54:53
HE tunnel a podobne typicky nefunguje za carrieer grade NAT.

IPv6 pouzivam pro vzdaleny pristup do domaci site.

Pokud to ISP umoznuje, muzu si jako alternativu zaplatit verejnou IPv4, ale tezko dostanu vic nez 1. Nicmene z principu to nechci podporovat, umet IPv6 mi v roce 2020 prijde normalni.
Vzdálený přístup (stejně jako třeba FTP, NAS a další) podstatně lépe obsloužím přes veřejnou pevnou IPv4, než přes IPv6.

K čemu víc IPv4? Byť u business exUPC je jich tuším 5 (1x pevná veřejná + 4x veřejná). To mělo význam snad kdysi v dobách Rapidshare, pokud chtěl člověk stahovat bez zaplacení a bez čekání dvou hodin, což by limit na volné stahování. Dneska naprostá zbytečnost.
A podpora? Rozhodující je funkčnost a ne nějaké morální nesmysly. Jinak tedy u exUPC lze přímo IPv6 také, pokud člověk nepotřebuje veřejnou IPv4, ale vystačí si s neveřejnou. To jenom pro úplnost.
Název: Re:IPv6 Poda
Přispěvatel: novak_josef_2019 15. 09. 2020, 18:18:14
Máme u nich na několika místech kamerový systém a IPv6 je ideální, na co platit za IPv4 veřejky. Ještě před optikou měli všichni jenom veřejky a to buď /30 nebo i /29. Poslední 2 roky veřejky zpoplatnili, i když všechny na optice přes IPv4 za-NAT-ovali, takže veřejek jim musely zbýt hromady.
Pokud budou k IPv6 stále všichni ISP přistupovat, jak za krále Klacka, tak se z těch 12% nezvedneme ani omylem, protože to už je skoro 2 roky stejné https://www.google.com/intl/en/ipv6/statistics.html#tab=per-country-ipv6-adoption .
Název: Re:IPv6 Poda
Přispěvatel: vlhab 15. 09. 2020, 21:04:09
HE tunnel a podobne typicky nefunguje za carrieer grade NAT.

IPv6 pouzivam pro vzdaleny pristup do domaci site.

Pokud to ISP umoznuje, muzu si jako alternativu zaplatit verejnou IPv4, ale tezko dostanu vic nez 1. Nicmene z principu to nechci podporovat, umet IPv6 mi v roce 2020 prijde normalni.
Vzdálený přístup (stejně jako třeba FTP, NAS a další) podstatně lépe obsloužím přes veřejnou pevnou IPv4, než přes IPv6.

K čemu víc IPv4? Byť u business exUPC je jich tuším 5 (1x pevná veřejná + 4x veřejná). To mělo význam snad kdysi v dobách Rapidshare, pokud chtěl člověk stahovat bez zaplacení a bez čekání dvou hodin, což by limit na volné stahování. Dneska naprostá zbytečnost.
A podpora? Rozhodující je funkčnost a ne nějaké morální nesmysly. Jinak tedy u exUPC lze přímo IPv6 také, pokud člověk nepotřebuje veřejnou IPv4, ale vystačí si s neveřejnou. To jenom pro úplnost.

Nevim proc sem pletete UPC, kde navic taky u rezidentnich zakazniku nefunguje PD v bridge modu, bavime se snad o Poda.

Na zbytek fakt nevim jak reagovat. Ja jsem se ptal na IPv6 a ne na to jak si mam nastavit sit nebo jak stahovat z Rapidshare. A mluvit o podpore IPv6 jako o “moralnim” hledisku, to uz je jak z diskuse na Novinkach.
Název: Re:IPv6 Poda
Přispěvatel: . 16. 09. 2020, 05:43:36
Asi proto, že se tady o exUPC celou dobu diskutuje souběžně s Poda. Občas je dobré si napřed přečíst všechny komentáře, než se bezhlavě vrhat do diskuze a zbrkle reagovat :P
Název: Re:IPv6 Poda
Přispěvatel: . 16. 09. 2020, 05:48:21
Máme u nich na několika místech kamerový systém a IPv6 je ideální, na co platit za IPv4 veřejky. Ještě před optikou měli všichni jenom veřejky a to buď /30 nebo i /29. Poslední 2 roky veřejky zpoplatnili, i když všechny na optice přes IPv4 za-NAT-ovali, takže veřejek jim musely zbýt hromady.
Pokud budou k IPv6 stále všichni ISP přistupovat, jak za krále Klacka, tak se z těch 12% nezvedneme ani omylem, protože to už je skoro 2 roky stejné https://www.google.com/intl/en/ipv6/statistics.html#tab=per-country-ipv6-adoption .
No to bude fakt hrozné neštěstí, když zůstane IPv6 na druhé koleji, jestli to vůbec lidé přežijí :D A pokud se bavíme o tom, proč raději pevná veřejná IPv4, tak třeba proto, že spousta zařízení (NAS atd.) si s IPv6 neporadí vůbec nebo sice ano, ale krkolomně (mizerně), zatímco na pevné veřejné IPv4 všechno funguje jak má, o což jde především.
Název: Re:IPv6 Poda
Přispěvatel: novak_josef_2019 16. 09. 2020, 11:10:23
NVR od Hikvision, které byly koupené v roce 2016 nemají s IPv6 žádný problém, to samé IP kamery ze stejné doby a od stejné firmy. Novější modely nemusím ani zmiňovat, bez problému na IPv6 funguje i RTSP stream přímo z kamery nebo přes NVR. I NAS, na kterém běží XPEnology funguje na IPv6, takže když to nějaký výrobce neumí, tak ať to nedělá.
Název: Re:IPv6 Poda
Přispěvatel: LukePole 16. 09. 2020, 14:14:13
Vždy lepší pevná veřejná IPv4, než dynamický prefix IPv6, který se může měnit. O tom snad netřeba debatovat.
Název: Re:IPv6 Poda
Přispěvatel: Hornik 16. 09. 2020, 14:46:10
Vždy lepší pevná veřejná IPv4, než dynamický prefix IPv6, který se může měnit. O tom snad netřeba debatovat.

Ktery op u nas poskytuje dynamicky prefix IPv6?
Název: Re:IPv6 Poda
Přispěvatel: novak_josef_2019 16. 09. 2020, 14:58:25
Vždy lepší pevná veřejná IPv4, než dynamický prefix IPv6, který se může měnit. O tom snad netřeba debatovat.
Na co budu u PODY platit 80,- Kč za jednu IPv4 veřejku, kde budu muset NATovat pro každou kameru nebo NVR extra port. Dodržují standard EUI-64, takže dopředu vím (podle prefixu + MAC), jakou bude mít zařízení IPv6 adresu a připojím se napřímo.
U PODY akorát hned na začátku nepochopili, že se dává rozsah aspoň /56.
Název: Re:IPv6 Poda
Přispěvatel: LukePole 16. 09. 2020, 21:13:17
Vždy lepší pevná veřejná IPv4, než dynamický prefix IPv6, který se může měnit. O tom snad netřeba debatovat.

Ktery op u nas poskytuje dynamicky prefix IPv6?
Spíš který OP garantuje prefix IPv6 fixní? Akorát O2 za příplatek kolem 200 Kč měsíčně.
Název: Re:IPv6 Poda
Přispěvatel: novak_josef_2019 16. 09. 2020, 21:47:11
Ze zákona musí logovat, takže pokud by musely dohledávat, kdo měl jaký prefix v určitou dobu, tak by se z toho opupínkovali. Nikdy se na routeru nezměnil a nejspíš bude přidělený k číslu smlouvy, takže by se nezměnil ani po výměně routeru za jiný, když by se při předání spároval se smlouvou.
Název: Re:IPv6 Poda
Přispěvatel: SB 17. 09. 2020, 09:16:35
Spíš který OP garantuje prefix IPv6 fixní? Akorát O2 za příplatek kolem 200 Kč měsíčně.

„Garantuje“ ve smyslu „má ve smlouvě“ asi žádný - není tajemstvím, že v provedení částí smluv popisujících vlastnosti připojení v ČR panuje středověk (klacek v podobě zákonu se ještě nevynašel), ale u T-Mobile mám vyzkoušeno, že prefix je pevný, mění se pouze v případě, že přečíslovávají síť, což je tak jednou za 3 roky.
Jestli má někdo dynamický prefix, tak je to síťové hovado.
Název: Re:IPv6 Poda
Přispěvatel: Hornik 17. 09. 2020, 09:22:33
Pro budouci generace:


Zari 2020

PODA "poskytuje IPv6 konektivitu" pro domacnosti na GPON, ale pouze /64 a bez PD.

Vedi, ze maji implementaci od zakladu spatne a planuji to napravit, ale neni to pro ne priorita.
Název: Re:IPv6 Poda
Přispěvatel: kuba 09. 10. 2020, 12:41:51
Zdravím,
už jsem psal dva e-maily na technickou podporu Pody, ale ani po dvou dnech jsem nedostal odpověď. Pokoušejí se mě naverbovat na jejich GPON internet a tvrdí, že mi zdarma přidělí veřejnou IPv6 adresu. Máte někdo zkušenosti s tím, jestli se tak dostanu (třeba přes port forwarding, nebo nějak jinak, moc nevím, jak to s IPv6 funguje) k zařízením v domácí síti z internetu? Co jsem četl, tak zákazníkům ani nedávají přístup do administrace routeru, takže jsem trochu skeptický a podpora se mnou odmítá komunikovat.

Díky moc.
Název: Re:IPv6 Poda
Přispěvatel: novak_josef_2019 09. 10. 2020, 16:02:17
Pokud budeš využívat jejich router, tak nastavení WiFi a portů (TV, NET) je v klientské zóně.
Všem zažízením za routrem bude přidělena IPv6, takže každé bude přes IPv6 globálně dostupné (žádný NAT + PF).
Název: Re:IPv6 Poda
Přispěvatel: d.r 14. 02. 2021, 04:17:37
Zdravím,
tak jen abych přihodil (sakra to je doba) update, pořád stejná 64. Ale nějak se mi to povedlo taky rozběhat (díky i radám zde) a tedy s ohledem na funkčnosti i na Androidu atd, ale holt pracujem s tím co máme :) Čert vem tu lenost co nám vzala tolik adres : )))))))))))))))))))))

Kdyby to někdo zas řešil tak na OpenWrt: wan bez veřejný, celej 64 na lan a v dhcp pak u wan6
Kód: [Vybrat]
config dhcp 'wan6'
        option interface 'wan6'
        option ra 'relay'
        option ndp 'relay'
        option master '1'
(tohle je asi to co vetsine chybí)

k lan
Kód: [Vybrat]
config dhcp 'lan'
        option interface 'lan'
        option ra 'hybrid'
        option ndp 'hybrid'
        option dhcpv6 'server'
        option ra_management '1'

Co se dhcpv6 týče tak ještě trochu experimentuju a řešení teda stojí za.... Nicméně vzhledem k situaci a co se problematiky týče tak můžu s klidem říct, že tomu absolutně nerozumím a nedělám si naděje, že někdy budu :D

D.
Název: Re:IPv6 Poda
Přispěvatel: Václav Jůza 04. 06. 2021, 00:04:34
Podařilo se někomu na tomhle pomocí openwrt udělat 2 LAN sítě (trusted a guest, v guestu jen wifi zařízení), aby v obou byla funkční (ideálně veřejná) IPv6, a zároveň stroje v trusted lan nebyly ohroženy z guest LAN?
Neúspěšně jsem zkoušel 3 přístupy, ale nejsem tak zkušený síťař:
1) Nakonfigurovat LAN to jako jednu síť, a pomocí ebtables filtrovat provoz z fyzických rozhraní pro guest zařízení. Jednak mi to filtrování nefungovalo, a jednak se obávám, že by to stejně nebylo moc bezpečný, jelikož bych nedokázal správně odfiltrovat např. non-IP provoz.
2) Nějak přimět npd router (NDP relay?) aby ten svůj delegovala na obě LAN sítě a pamatoval si, která IPv6 adresa je ve které síti (nebo je to blbost?) Každopadně, když jsem obě lan sítě nastavil podobně, jako je např. v předchozím příspěvku, prefix byl delegován jen na jednu z nich.
3) Nastavit DHCPv6 a přidělovat /66 prefixy (někdo zde podobné řešení zmiňoval) - nepodařilo se mi rozchodit. Čekal jsem nefunkčnost u androidu, ale ani plnohodnotný Linux příslušný veřejný prefix neobdržel, přišlo mi, že openWrt přidělování čehokoli menšího než 64 sabotuje.
4) Jsem ještě nezkoušel, protože se mi to trochu příčí - na guest síti použít IPv6 NAT, aby byla aspoň konektivita na IPv6 only internet.

Máte na tyto možnosti někdo názor, nebo vám to dokonce chodí?
Název: Re:IPv6 Poda
Přispěvatel: Hornik 04. 06. 2021, 08:42:57
Cerven 2021


PODA "poskytuje IPv6 konektivitu" pro domacnosti na GPON, ale pouze /64 a bez PD.

Vlastni ONT neni mozne.


Vedi, ze maji implementaci od zakladu spatne a planuji to napravit, ale neni to pro ne priorita.

:(
Název: Re:IPv6 Poda
Přispěvatel: Martin Oles 04. 06. 2021, 12:23:22
Nevhodná implementace IPv6 na Poda GPON (/64) + Mikrotik nepodporuje ND proxy = musel jsem zůstat u IPv6 brokera  :(
Název: Re:IPv6 Poda
Přispěvatel: Hornik 04. 06. 2021, 15:56:11
Ja mam nastesti OpenWRT, kde se to da uhackovat do "funkcnosti".

Doufam, ze jste vyprudil PODA support linku!
Název: Re:IPv6 Poda
Přispěvatel: Jan Maryška 06. 08. 2021, 06:20:26
Vždy lepší pevná veřejná IPv4, než dynamický prefix IPv6, který se může měnit. O tom snad netřeba debatovat.

Ktery op u nas poskytuje dynamicky prefix IPv6?

Třeba O2 statický IPV6 prefix je za 129 korun.
Název: Re:IPv6 Poda
Přispěvatel: Ondřej Caletka 06. 08. 2021, 09:19:59
Třeba O2 statický IPV6 prefix je za 129 korun.
…což jsou asi nejzbytečněji vynaložené peníze, protože ani ten „dynamický” prefix se v čase obvykle nemění, maximálně jednou za několik let, při nějaké větší reorganizaci. A při té je dost pravděpodobné, že vám nakonec změní i ten statický prefix, protože to prostě bude technicky nutné. Jen vám to za těch 129 Kč měsíčně nahlásí dopředu. To se vyplatí!  :D