Fórum Root.cz

Hlavní témata => Software => Téma založeno: Arhtista 24. 05. 2018, 22:29:12

Název: Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: Arhtista 24. 05. 2018, 22:29:12
Ahoj, v Opeře mi přestaly fungovat některé weby jedoucí na https. (nevím jak dlouho minimálně 2 roky) Ukáže to klasickou opera chybovou stránku (skutečně zadávám url s https nebo bez něj, ačkoli se v hlášce ukazuje http)
Kód: [Vybrat]
Nepodařilo se dokončit zabezpečenou operaci

Pokoušíte se přistoupit na adresu http://..., která je nyní nedostupná. Zkontrolujte, zda je adresa zadána správně, a pak zkuste stránku načíst znovu.

Zabezpečené připojení: kritická chyba (40)

https://gdpr.billa.cz/

Chyba při připojení k serveru. Důvodem může být nastavení vašeho prohlížeče, které nepovoluje použití šifrovacích metod podporovaných serverem.

Berte na vědomí, že některé méně bezpečné šifrovací metody již nejsou prohlížečem podporovány. Jejich vyžadování serverem může návštěvníkovi znemožnit přístup, dokud nebude web aktualizován pro použití silného šifrování.

Například root jde (TLS v1.2 256 bit AES (2048 bit DHE_RSA/SHA-256))

Nevíte, jak to opravit, aby mi ty weby chodili v Opeře 12?  Možná to souvisí, ale podobný problém jsem měl na symbianu (některé šly, některé ne), tam jsem nainstaloval Network_improvements.sisx a šlo to. (období asi 6-3 roky zpět)
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: Jenda 25. 05. 2018, 00:39:43
https://www.ssllabs.com/ssltest/viewMyClient.html

A vůbec, 4 roky starý browser? Really?
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: soriako 25. 05. 2018, 01:21:28
nic si z toho nedělej, mě už na IE6 taky máloco funguje  ;)
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: jejda 25. 05. 2018, 07:21:09
Co máš za systém? Poslední presto opera pro linux byla 12.16 myslím. Jestli máš linux, tak něco podobnýho se před časem řešilo  na Abíčku  (http://www.abclinuxu.cz/poradna/linux/show/425392#19) . Jestli máš windows tak nainstaluj 12.18.
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: Johnny 25. 05. 2018, 16:44:23
Hádám, že to bude tím, že si navzájem nerozumí, viz https://www.ssllabs.com/ssltest/analyze.html?d=gdpr.billa.cz (https://www.ssllabs.com/ssltest/analyze.html?d=gdpr.billa.cz)
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: Jiří Eischmann 25. 05. 2018, 16:56:20
https://www.ssllabs.com/ssltest/viewMyClient.html

A vůbec, 4 roky starý browser? Really?

Taky jsem si říkal. Ale někoho asi baví chodit s holým zadkem do trní :-)
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: Lol Phirae 25. 05. 2018, 17:14:12
Hádám, že to bude tím, že si navzájem nerozumí, viz https://www.ssllabs.com/ssltest/analyze.html?d=gdpr.billa.cz (https://www.ssllabs.com/ssltest/analyze.html?d=gdpr.billa.cz)

Což je vzhledem ke stáří prohlížeče skutečně šokující odhalení...  ;D
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: nobody(ten pravej) 26. 05. 2018, 01:43:47
@Arhtista
Bohuzel o reseni nevim, resp. muzes zkusit pouvivat na to co nejde v Opera12 prohlizec Vivaldi (je od stejneho zakladatele Opery a casti jejich puvodnich vyvojaru, a strucne receno je v nem reinkarnovat duch (puvodni) Opery), takto sem par let fungoval...
Druha moznost je, ze si nainstalujes Windows verzi 12.18 (ktera byla vydana prave/jen kvuli aktualizaci podporovanych certifikatu) a provozovat to pres Wine, sice UI bude nepatrne odlisne od nativni GNU/Linux Opery12, ale jinak (co jsem ji pri vydani zkousel) chodila pod Wine bez problemu... treti (teoreticka) moznost viz nasledujici odpoved

@jejda
jak si psal na abc, tak uz sem ti tam zapomel odpovedet, ale tvuj postup mi nefungoval, opravdu ti to funguje? ;-) nedelal si naahodou jeste neco jineho aby jsi ty soubory s win verze zprovoznil?

@Jenda, @Jiří Eischmann, @Lol Phirae
Opera 12 je sice stara, ale je stale neprekonana, jak nenarocnost, rychlost, moznosti nastaveni atd... sice uz sem asi pred pul rokem jako primarni prohlizec ji nahradil Vivaldi (kterej ma vetsinu moznosti Opera12(i kdyz krome (pro me zajimavych) seskupovani listu, rychlosti), nicmene chapu lidi co na ni stale zustavaji, ten kdo to nechape(te) jste ji asi nikdy nepouzivali ;-)
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: Jiří Eischmann 26. 05. 2018, 16:04:08
Starou Operu jsem používal, dokonce jsem byl jedním z jejich největších propagátorů v ČR, ale je to prostě mrtvá věc. Kompatibilita s aktuálními webovými technologiemi špatná, bezpečnost strašlivá. A lepší už to nebude, naopak se to bude jenom zhoršovat.
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: hawran diskuse 26. 05. 2018, 19:31:36
...
@Jenda, @Jiří Eischmann, @Lol Phirae
Opera 12 je sice stara, ale je stale neprekonana, jak nenarocnost, rychlost, moznosti nastaveni atd... sice uz sem asi pred pul rokem jako primarni prohlizec ji nahradil Vivaldi (kterej ma vetsinu moznosti Opera12(i kdyz krome (pro me zajimavych) seskupovani listu, rychlosti), nicmene chapu lidi co na ni stale zustavaji, ten kdo to nechape(te) jste ji asi nikdy nepouzivali ;-)

 :o  :o  :o
Lpět na 4 roky starém krámu v době, když se den co den řeší všelijaké díry skoro ve všem, to chce fakt odvahu...
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: nobody(ten pravej) 26. 05. 2018, 23:47:30
Starou Operu jsem používal, dokonce jsem byl jedním z jejich největších propagátorů v ČR, ale je to prostě mrtvá věc. Kompatibilita s aktuálními webovými technologiemi špatná, bezpečnost strašlivá. A lepší už to nebude, naopak se to bude jenom zhoršovat.
Tak si ji asi pouzival a propagoval pro image a ne pro jeji vlasnosti ;-) Kdyby nebyli propadne certifikaty, tak 99% dnesnich webu v Opera12 chodilo v pohode... to jedno procento aplikacnich praso webu se dalo pouzivat v jinem prohlizeci...

@hawran diskuse tak 12.18 je stara 2 roky ;-) nicmene slo mi o to ze vlastnosti Opery12 jsou stale neprekonane, neni to zadne lpeni (navic sem psal ze pred pul rokem sem uz presel na primarne Vivaldi), jen chapu proc se ji nekdo drzi i pres ostatni minusy...
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: jejda 27. 05. 2018, 00:33:25
@jejda
jak si psal na abc, tak uz sem ti tam zapomel odpovedet, ale tvuj postup mi nefungoval, opravdu ti to funguje? ;-) nedelal si naahodou jeste neco jineho aby jsi ty soubory s win verze zprovoznil?
Pravda dělal jsem s operou všelijaké kejkle aby přestala zlobit. Nějaký postup krok po kroku už ale dohromady nedám. :-(
V operaprefs.ini mám:

[Security Prefs]
Enable TLS v1.0=1
Enable TLS v1.1=1
Enable TLS v1.2=1
Enable SSL v3=0
OCSP Validate Certificates=0


webový+ftp provoz si cedím přes squid proxy který kešuje/filtruje všecko včetně https a dělám si vlastně takový selfMITM  ;D. Nevím proč ale opera úplně ignoruje systémové certikáty z /etc/ssl/ tak aby toto fungovalo bylo potřeba ten squidí certifikát naimportovat přímo do opery. Nicméně aji když se připojím napřímo bez proxy, tak ten web https://gdpr.billa.cz/ v opeře funguje, tak jsem se o proxy nezmiňoval abych tazatele zbytečně nedoplantal.
Napadá mě ještě, jestli já jsem tenktrát do opery ručně nepřidával nějaké další certifikáty ...? Ale už si to vážně nepamatuju, dělal jsem s tím psí kusy :-(
Nahrál jsem ty soubory  na uložto  (https://uloz.to/!n2HxRTkOujIk/opera-error40-tar-gz) jestli to třeba pomůže.
Addony používám jenom tři.  violentmonkey  (https://github.com/violentmonkey/violentmonkey-oex/releases)  ,  google classic  (https://addons.opera.com/en/extensions/details/google-classic/) a  scriptweeder  (https://addons.opera.com/en/extensions/details/scriptweeder/) ale ty by snad nemusely mít s tim ssl errorem nic co do činění.
:o  :o  :o
Lpět na 4 roky starém krámu v době, když se den co den řeší všelijaké díry skoro ve všem, to chce fakt odvahu...
Program se ti časem nezkazí jak jogurt nebo salám ani se intenzivním používáním nijak neošoupe  ;) a pokud jde o bezpečnost, tak s vypnutým javascriptem to není zas až taková hrůza. Horší je, že webů se kterýma má opera problém postupně přibývá, takže člověk musí stejně mět v záloze firefox/vivaldi a pokud máš slabší stroj je to utrpení.
 Když si to tak veznu z pohledu uživatele, na webu máš furt převážně  2D text s 2D obrázkama, toto tu bylo před 20ti rokama taky a to byly počítače 50x pomalejší jak dneska. Těch pár nových fičur navíc co teď máme, rozhodně nemůže omluvit ty stonásobné nároky na hardware! Další věc je javascript. Snaha přenášet zátěž ze serveru na klienta pomocí javascriptu mohla mít snad smysl v době, kdy většina uživatelů surfovala na svojich domácích nabušených pécéčkách. Dneska většina uživatelů webu používá různé šmatlací krabičky s mizerným výkonem v lepším případě notebooky. Jak se toto bude řešit netuším 
Když už se tenkrát rozhodli verzi 12 kompletně pohřbít, mohli aspoň uvolnit zdrojáky jako opensource. Určitě by se toho někdo chytnul. Je veliká škoda nechat takový docela luxusní kus software chcípnout. Uživatelů opera neměla málo. Takto se musí  vymýšlet náhražky  (https://otter-browser.org/). Myslím že opera měla svůj vrchol ve verzi 9. Byla malá, rychlá a uměla toho 2x víc jak ostatní browsery. S příchodem verze 10 a html5 už začala nezřízeně bobtnat, měnit barvy tvary chutě, zpomalovat. Až ju ta webová rakovina nakonec dostala na lopatky.  :'(
Nevíte o nějakým poštovním klientovi pro linux který umí zobrazit maily z několika různých účtů hezky pod sebou na jednom seznamu tak jak to umí ten pošťák v opeře? Prostě když kliknu třeba na "Unread" tak to zobrazí nepřečtené maily ze všech účtů. Nebo to vyhledávání, automaticky prohledává všecky účty když nemám zakliknutý nějaký konkrétní ..atd. Co jsem tak zkoušel tak všude se muselo nějak přepínat mezi profilama, to je dost nepřehledný když je těch účtů trochu víc. Mám jich asi 20-30.
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: Kkt2 27. 05. 2018, 08:23:40
@jejda
jak si psal na abc, tak uz sem ti tam zapomel odpovedet, ale tvuj postup mi nefungoval, opravdu ti to funguje? ;-) nedelal si naahodou jeste neco jineho aby jsi ty soubory s win verze zprovoznil?
Pravda dělal jsem s operou všelijaké kejkle aby přestala zlobit. Nějaký postup krok po kroku už ale dohromady nedám. :-(
V operaprefs.ini mám:

[Security Prefs]
Enable TLS v1.0=1
Enable TLS v1.1=1
Enable TLS v1.2=1
Enable SSL v3=0
OCSP Validate Certificates=0


webový+ftp provoz si cedím přes squid proxy který kešuje/filtruje všecko včetně https a dělám si vlastně takový selfMITM  ;D. Nevím proč ale opera úplně ignoruje systémové certikáty z /etc/ssl/ tak aby toto fungovalo bylo potřeba ten squidí certifikát naimportovat přímo do opery. Nicméně aji když se připojím napřímo bez proxy, tak ten web https://gdpr.billa.cz/ v opeře funguje, tak jsem se o proxy nezmiňoval abych tazatele zbytečně nedoplantal.
Napadá mě ještě, jestli já jsem tenktrát do opery ručně nepřidával nějaké další certifikáty ...? Ale už si to vážně nepamatuju, dělal jsem s tím psí kusy :-(
Nahrál jsem ty soubory  na uložto  (https://uloz.to/!n2HxRTkOujIk/opera-error40-tar-gz) jestli to třeba pomůže.
Addony používám jenom tři.  violentmonkey  (https://github.com/violentmonkey/violentmonkey-oex/releases)  ,  google classic  (https://addons.opera.com/en/extensions/details/google-classic/) a  scriptweeder  (https://addons.opera.com/en/extensions/details/scriptweeder/) ale ty by snad nemusely mít s tim ssl errorem nic co do činění.
:o  :o  :o
Lpět na 4 roky starém krámu v době, když se den co den řeší všelijaké díry skoro ve všem, to chce fakt odvahu...
Program se ti časem nezkazí jak jogurt nebo salám ani se intenzivním používáním nijak neošoupe  ;) a pokud jde o bezpečnost, tak s vypnutým javascriptem to není zas až taková hrůza. Horší je, že webů se kterýma má opera problém postupně přibývá, takže člověk musí stejně mět v záloze firefox/vivaldi a pokud máš slabší stroj je to utrpení.
 Když si to tak veznu z pohledu uživatele, na webu máš furt převážně  2D text s 2D obrázkama, toto tu bylo před 20ti rokama taky a to byly počítače 50x pomalejší jak dneska. Těch pár nových fičur navíc co teď máme, rozhodně nemůže omluvit ty stonásobné nároky na hardware! Další věc je javascript. Snaha přenášet zátěž ze serveru na klienta pomocí javascriptu mohla mít snad smysl v době, kdy většina uživatelů surfovala na svojich domácích nabušených pécéčkách. Dneska většina uživatelů webu používá různé šmatlací krabičky s mizerným výkonem v lepším případě notebooky. Jak se toto bude řešit netuším 
Když už se tenkrát rozhodli verzi 12 kompletně pohřbít, mohli aspoň uvolnit zdrojáky jako opensource. Určitě by se toho někdo chytnul. Je veliká škoda nechat takový docela luxusní kus software chcípnout. Uživatelů opera neměla málo. Takto se musí  vymýšlet náhražky  (https://otter-browser.org/). Myslím že opera měla svůj vrchol ve verzi 9. Byla malá, rychlá a uměla toho 2x víc jak ostatní browsery. S příchodem verze 10 a html5 už začala nezřízeně bobtnat, měnit barvy tvary chutě, zpomalovat. Až ju ta webová rakovina nakonec dostala na lopatky.  :'(
Nevíte o nějakým poštovním klientovi pro linux který umí zobrazit maily z několika různých účtů hezky pod sebou na jednom seznamu tak jak to umí ten pošťák v opeře? Prostě když kliknu třeba na "Unread" tak to zobrazí nepřečtené maily ze všech účtů. Nebo to vyhledávání, automaticky prohledává všecky účty když nemám zakliknutý nějaký konkrétní ..atd. Co jsem tak zkoušel tak všude se muselo nějak přepínat mezi profilama, to je dost nepřehledný když je těch účtů trochu víc. Mám jich asi 20-30.
Jenom takova technicka-jak validujes certifikaty na tom squidu? Ignorujes chyby? Overujes revokaci?
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: jejda 27. 05. 2018, 09:37:34
Tu proxy používám jenom já, bezpečnost moc neřeším. Ve squid.conf mám:
sslproxy_flags DONT_VERIFY_PEER
 Abych se přiznal tak ani pořádně nevím jaký jsou rizika. Jsem rád že to vůbec nějak funguje.
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: kkt1 27. 05. 2018, 11:06:44
Tu proxy používám jenom já, bezpečnost moc neřeším. Ve squid.conf mám:
sslproxy_flags DONT_VERIFY_PEER
 Abych se přiznal tak ani pořádně nevím jaký jsou rizika. Jsem rád že to vůbec nějak funguje.
no rizika jsou ta, ze ti nekdo udela mitm a ty misto sve banky zadas heslo nekomu jinemu kdyz nic neoverujes... bankovni aplikace tohle maji overeno pres certificate pinning (obvykle), u weboveho prohlizece tohle neni.
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: hawran diskuse 27. 05. 2018, 14:17:19
Starou Operu jsem používal, dokonce jsem byl jedním z jejich největších propagátorů v ČR, ale je to prostě mrtvá věc. Kompatibilita s aktuálními webovými technologiemi špatná, bezpečnost strašlivá. A lepší už to nebude, naopak se to bude jenom zhoršovat.
Tak si ji asi pouzival a propagoval pro image a ne pro jeji vlasnosti ;-) ...
Hm, to je hodně odvážně tvrzení.

@hawran diskuse tak 12.18 je stara 2 roky ;-) ...
Ano, to je vzhledem k překotnému "vývoji" chyb, průserů, ... opravdu hodně aktuální!
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: hawran diskuse 27. 05. 2018, 14:20:37
...
Nevíte o nějakým poštovním klientovi pro linux který umí zobrazit maily z několika různých účtů hezky pod sebou na jednom seznamu tak jak to umí ten pošťák v opeře? ...
Tak, tak, není nad webový prohlížeč, který je i emailový klient.
Doufám, že to umí i přehrávat mp3 a otvírat garážová vrata na dálku...
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: Lol Phirae 27. 05. 2018, 14:59:37
Tak, tak, není nad webový prohlížeč, který je i emailový klient.

Mám takový neblahý dojem, že součástí té věci byl i webserver.  ::)
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: nobody(ten pravej) 28. 05. 2018, 15:47:10
Mám takový neblahý dojem, že součástí té věci byl i webserver.  ::)
Ano MOHL sis zapnout webserver pro sdileni...
Jinak ten email klient byl kvalitnejsi nez vetsina standalone, zaroven implementoval vybornou rss ctecku, irc klienta, torrent klienta, gesta na ovladani prohlizeni a hromadu dalsich veci na ktere jine prohlizece vyzaduji rozsireni... a to vse v binarce kolem 10MB, tedy zlomek toho co zabere prohlizes s 1% moznosti...
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: IKS 05. 10. 2018, 06:31:47
Importovat do O12.xx certifikáty z jiného prohlížeče, kde to jede normálně.Jde to.
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: Lojza 05. 10. 2018, 07:52:39
Importovat do O12.xx certifikáty z jiného prohlížeče, kde to jede normálně.Jde to.
chtelo by to nejaky navod z ktereho prohlizece jak exportovat a jak naimportovat do opery 12
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: iks 05. 10. 2018, 16:16:16
třeba z firefoxu. Klinknout na začátek adresního řádku, aby se zobrazily informace o zabezpečení, proklikat se na informace->zabezpečení->zobrazit certifikát->podrobnosti->exportovat.

V Opeře: Nástroje-nastavení-pokročilé volby-zabezpečení-správce certifikátů-importovat.
Zde importuješ cert, který jsi ve FF exportoval.

Opera 12.xx funguje stále a všude, chce si s ní jen trochu pohrát. :)
Název: Re:Opera 12.17: nefungují některé HTTPS (critical error (40)).
Přispěvatel: m. 06. 10. 2018, 15:02:31

Ano, to je vzhledem k překotnému "vývoji" chyb, průserů, ... opravdu hodně aktuální!

Teoreticky by mohla 4 roky stara opera nejt bezpecnejsi nez 2 roky stara. Pochybuju, ze nekdo bude cilit na par poslednich uzivatelu 4 roky stareho, silne minoritniho prohlizece.