Tak mi přistál na stole router a řeším, jak do něj namlátit lokální DNS a přemýšlím, jakou top level doménu zneužít. Bohužel ty krámy v LAN neumí koketně všechy mDNS, takže spoléhat na .local je asi pasé. Situace je o to závažnější, že je to pro mou vlastní tchýni, takže nutná obezřetnost vyšší, než pracovní řešení zařízení v kategori A+ (s přímým vlivem na jadernou bezpečnost).
Tak dejme doménu .polecat.<něco> a co použít jako <něco>? .local je pro mDNS, to je neslušnost, pořídit si něco z nových TLD (typu .xyz) je asi zbytečnost.
Tak pak přes obecnou nedoporučovnaost takového řešení, zbývá něco z hintů v RFC6762 z .intranet/.internal/.private/.corp/.home/.lan? .corp bych vynechal, jako důchodkyni ji pracovním tématem trápit netřeba. Hlasoval bych pro .lan, ale pokud je pravda toto: https://www.linx.net/icann-protects-home-mail-corp-registration/ pak asi nejlépe .home? Pár RFC to nějak řeší, .home je zmíněno, pak upraveno na .home.arpa (RFC8375), IPv6 zase razí zásadu .sitelocal (RFC7368), nicméně .home.arpa i .sitelocal chápu, že je určeno pro autokonfigurační řešení a ne, že si namlátím DNS staticky...
.polecat je pekne.
z ceho vzniklo slovo tchyne?! spojenim tchor a svine.
napadaji me vtipne nazvy:
.svokra
.tchn
.diebtch
.crematorium
:-)
Ja pouzivam doma domenu ".here". Povodne som pouzival ".local" ale prave kvoli potencialnym konfliktom s mDNS som to zmenil.
Citace od: MartinXXX kdy 25. 01. 2019, 23:28:14
Ja pouzivam doma domenu ".here". Povodne som pouzival ".local" ale prave kvoli potencialnym konfliktom s mDNS som to zmenil.
po vzoru OOP jazyku jako c++ by se mohlou pouzit .this :-)
kup jí nějakou doménu a za pár korun ročně to nebudeš muset řešit
K cemu to je?
Žádnou.
Tiez nechapem naco je dobra svokre domena.
Citace od: Ondro kdy 26. 01. 2019, 10:35:56
Tiez nechapem naco je dobra svokre domena.
Některé služby doménu vyžadují.
.doma
Pokud je to lokální doména, tak není třeba se trápit a prostě tam něco dát.
.moje
.pivo
.kripl
.trenky
.<cokoli>
Mám takhle udělané 3 domácnosti s lokální doménou .<příjmení> a jednu pro VPN rozhraní. Na routerech mi jede OpenWRT s ISC DHCP a BINDem, nicméně to není podmínka.
A proc pouzivat TLD? Kdyz mas koupenou normalni domenu 2 radu, tak si vytvor domenu tretiho radu na tyhle ucely, ne?
*.home.domena.cz, resp. muzes podle lokace, *.tchyne.rodina.cz.
Ja takto pouzivam podle mesta *.prg.domena.cz, resp. virtualni sit... *.vpn.domena.cz
ja pouzivam .doma
Takže se bude překládat jinak z venku i uvnitř? Není to rovnák na ohýbák? Používám to tak a přjde mi logické, že doma je to server.hacienda a z venku server.myhomedomain.cz
Citace od: RDa kdy 26. 01. 2019, 17:35:11
A proc pouzivat TLD? Kdyz mas koupenou normalni domenu 2 radu, tak si vytvor domenu tretiho radu na tyhle ucely, ne?
*.home.domena.cz, resp. muzes podle lokace, *.tchyne.rodina.cz.
Ja takto pouzivam podle mesta *.prg.domena.cz, resp. virtualni sit... *.vpn.domena.cz
Citace od: Javor kdy 26. 01. 2019, 21:54:20
Takže se bude překládat jinak z venku i uvnitř? Není to rovnák na ohýbák? Používám to tak a přjde mi logické, že doma je to server.hacienda a z venku server.myhomedomain.cz
A co mas nastaveno v hostname/domain na tom stroji ?
Citace od: M. kdy 25. 01. 2019, 23:01:32
(...)
vlastní tchýni, takže nutná obezřetnost vyšší, než pracovní řešení zařízení v kategori A+ (s přímým vlivem na jadernou bezpečnost).
Tak dejme doménu .polecat.<něco> a co použít jako <něco>? .local je pro mDNS, to je neslušnost, pořídit si něco z nových TLD (typu .xyz) je asi zbytečnost.
(...)
.XXX
Dlouho jsem doma používal ".home" , ale cca před rokem to nějak začalo blbnout. Bohužel si už nevzpomenu co přesně. Ale po nějakém googlení z toho vypadlo, že jsem musel ještě přidat doménu 2. řádu na "neco.home".
Citace od: Javor kdy 26. 01. 2019, 21:54:20
Takže se bude překládat jinak z venku i uvnitř? Není to rovnák na ohýbák? Používám to tak a přjde mi logické, že doma je to server.hacienda a z venku server.myhomedomain.cz
...
Tak to ti prijde logicky uplne spatne ... co davas do nastaveni vsemoznych aplikaci? A kdyz des ven tak to pokazdy menis? lol ... proto se to dela tak, aby zvenku i zevnitr bylo dns stejny, meni se jen IP kterou server vrati.
Citace od: j kdy 28. 01. 2019, 10:15:22
Citace od: Javor kdy 26. 01. 2019, 21:54:20
Takže se bude překládat jinak z venku i uvnitř? Není to rovnák na ohýbák? Používám to tak a přjde mi logické, že doma je to server.hacienda a z venku server.myhomedomain.cz
...
Tak to ti prijde logicky uplne spatne ... co davas do nastaveni vsemoznych aplikaci? A kdyz des ven tak to pokazdy menis? lol ... proto se to dela tak, aby zvenku i zevnitr bylo dns stejny, meni se jen IP kterou server vrati.
Tak tak. Kdejaký NAS chce/umožňuje SSL, když mám identickou doménu zevnitř i z venku, můžu mít validní certifikát třeba od Let's Encrypt.
Citace od: Javor kdy 26. 01. 2019, 21:54:20
Tak to ti prijde logicky uplne spatne ... co davas do nastaveni vsemoznych aplikaci? A kdyz des ven tak to pokazdy menis? lol ... proto se to dela tak, aby zvenku i zevnitr bylo dns stejny, meni se jen IP kterou server vrati.
Jak se to dá nastavit? Osobně mám třeba takhle z venku dostupný NAS, ale jak jsem u sebe na síti doma, tak se na nas pod tou doménou nedostanu. Jen bohužel nevím, jak to nastavit na routeru, aby to nebyl problém.
Citace od: perteus kdy 29. 01. 2019, 12:27:02
Citace od: Javor kdy 26. 01. 2019, 21:54:20
Tak to ti prijde logicky uplne spatne ... co davas do nastaveni vsemoznych aplikaci? A kdyz des ven tak to pokazdy menis? lol ... proto se to dela tak, aby zvenku i zevnitr bylo dns stejny, meni se jen IP kterou server vrati.
Jak se to dá nastavit? Osobně mám třeba takhle z venku dostupný NAS, ale jak jsem u sebe na síti doma, tak se na nas pod tou doménou nedostanu. Jen bohužel nevím, jak to nastavit na routeru, aby to nebyl problém.
V podstatě mě napadají 2 možnosti :
1) Hairpin NAT - https://wiki.mikrotik.com/wiki/Hairpin_NAT
2) Split DNS - https://www.webopedia.com/TERM/S/split_DNS.html